Jump to content
AGuser

Konfiguration Vodafone SIP-Trunk

Recommended Posts

Hallo zusammen,

 

es wird gerade versucht, eine Testrufnummer, für einen Vodafone-SIP-Trunk zu konfigurieren.

Keine SIP-Gateway, direkte Anbindung an Vodafone.

 

Profilauswahl von Vodafone, für den SIPTRUNK, steht in der aktuelle verwendetet Version: 11.52.13294 zu Verfügung:

 

SIP Provider Vodafone (DE) – Swyx Help Center

 

Folgende Informationen und Daten liegen für den Test vor:

 

Rufnummer:

 

SIP_User.jpg.07a9c0c824cd26a81e65a48679d8ea51.jpg

 

Registrar-Infos:

SIP_Registrierung.jpg.10bd62827432d1846c2c6b99a5dd80a7.jpg

 

 

Leider scheitert die Konfiguration schon bei der Eingabe der Daten in den Eigenschaften des SIPTRUNKS:

 

SIPTRUNK_Konfiguration.jpg.d0f11e8ab758236facb5b18d2088c206.jpg

 

 

Welche Daten müssen wo eingetragen werden?

Wo sieht man die Testrufnummer, nach einer erfolgreichen Registrierung, damit diese einem Benutzer zugeordnet werden kann?

 

Kann da jemand evtl. weiterhelfen? 

HowTo oder ein Beispiel wurde nicht gefunden(übersehen?).

 

Falls jemand was weiß oder noch Infos benötigt,

bitte melden.

 

Danke.

 

MfG

 

AGuser

 

 

Share this post


Link to post
Share on other sites

Hallo HansWurst,

 

vielen Dank für die Antwort.

 

Proxy und Realm hab ich entsprechend eingetragen.

 

SIP-Kennwort gibt es nicht, da es keine SIP-Registrierung gibt, hier folgend Antwort von Vodafone, auf Nachfrage:

 

Quote

SIP User/ Pass brauchen Sie nicht, weil unser SIP Trunk keine SIP / User Name Registrierung hat. Die TK-Anlage soll nur auf Option Ping von SBC alle 60 Sek antworten und Sie sollen auf SIP Parameter (wie Transport Protokoll / PAI SIP Header und Ports) beim ausgehenden SIP invites achten.

 

Stehe etwas auf dem Schlauch, daher die Frage, ob das jemand schon gemacht hat oder es dazu ein HowTo anhand eine Beispiels gibt?

Share this post


Link to post
Share on other sites

unter SIP Registrierung brauchst du nichts einzutragen, da Vodafone nicht mit Registrierung arbeitet. Vodafone nutzt deine öffentliche IP (PBX IP), deine Firewall muss dann entsprechend konfiguriert sein

Unter Rufnummer trägst die Rufnummer von bis ein, also 7719370 bis 7719379. Im Reiter Rufnummernsignalisierung wählst du "Rufnummer des  Anrufers signalisieren aus". Unter Codecs eventuell T.38 deaktivieren, bin mir gerade nicht sicher, ob Vodafone das unterstützt.

Wenn du alles eingetragen hast und deine Firewall konfiguriert ist, dann sollte es funktionieren. Am besten mit Wireshark überprüfen, da der Trunk registrierungslos ist und als "angemeldet" angezeigt wird

Share this post


Link to post
Share on other sites
2 hours ago, SvenS said:

unter SIP Registrierung brauchst du nichts einzutragen, da Vodafone nicht mit Registrierung arbeitet. Vodafone nutzt deine öffentliche IP (PBX IP), deine Firewall muss dann entsprechend konfiguriert sein

Unter Rufnummer trägst die Rufnummer von bis ein, also 7719370 bis 7719379. Im Reiter Rufnummernsignalisierung wählst du "Rufnummer des  Anrufers signalisieren aus". Unter Codecs eventuell T.38 deaktivieren, bin mir gerade nicht sicher, ob Vodafone das unterstützt.

Wenn du alles eingetragen hast und deine Firewall konfiguriert ist, dann sollte es funktionieren. Am besten mit Wireshark überprüfen, da der Trunk registrierungslos ist und als "angemeldet" angezeigt wird

 

Hallo SvenS,

 

danke. Bin jetzt einen Schritt weiter gekommen.

 

Laut Durchwahlbereich, stehen die Rufnummern: ...37-0 bis ...37-9 zur Verfügung.

 

Wie wird jetzt einem Benutzer die einzelne Rufnummer(Durchwahl) zugewiesen?

 

Bei einem Testbenutzer sieht das nun wie folgt aus:

 

OeffentlicheRufnummerZuordnen.jpg.5330c0aab4c4891ca5b0713582c56578.jpg

 

 

 

Des Weitern sind mit dem Testbenutzer nun ausgehende Telefonate möglich,

jedoch wenn im Reiter "Rufnummernsignalisierung", die Option "Rufnummer immer unterdrücken" gesetzt wird bzw. egal welche Option gesetzt wird, wird immer die momentane Zentrale-Rufnummer(bisheriger ISDN-Anschluss) ausgehend angezeigt.

Es wird nicht die Rufnummer des neuen Trunks verwendet.

 

SIP_Rufnummersignalisierung.thumb.jpg.68c4b65194cb91e5b6fb4e9bbf09a27c.jpg

 

Hab auch mit folgenden Optionen der Trunk-Gruppe probiert, bringt aber keine Änderung.

 

Nummernformatierung.jpg.1ea53aee2bdfcc6a235e775dace2589c.jpg

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Also die Rufnummer ist auch richtig eingetragen in der Trunkkonfiguration ? Das Rufnummernformat bei Vodafone SIP ist "Kanonisch mit +" . 

image.png.dba77b6491c7f92da11486d523b90a9e.pngimage.png.569ae15a2b5141a05746f8b2debc102c.png

 

Bei deinem Testuser musst du über "Auswählen" die richtige Nummer auswählen und unten im Feld "Zugewiesene öffentliche Rufnummer die Nummer eintragen.

image.png.fa6cafe983e1b05feb6d6de634979080.png

 

Damit der User auch über den Vodafone Trunk raustelefoniert, musst du entweder einen Weiterleitungseintrag erstellen mit höherer Priorität und als Quelle dein Testuser oder du Konfigurierst in der Trunkgruppe einen Auswahlprefix (z.B. **37#), den musst du dann immer Vorwählen und dann die eigentliche Nummer

 

Share this post


Link to post
Share on other sites

Hallo SvenS,

 

Rufnummer ist richtig eingetragen.

 

"Auswählen" zur Rufnummernzuordnung ist der richtige Weg, nicht via "Drop-Down-Menü" 😅

 

Weiterleitungseintrag ist gesetzt, hier "700" höher als die "500" bei der vorhandenen Trunk-Gruppe + Zuweisung des Testusers: 

 

Weiterleitungstabelle_700.jpg.c7b8ac3faa7658ed45418e9cf1070d0d.jpg

 

Beim ausgehenden Anruf, sieht man nun, dass der Ziel-Trunk "Vodafone" ist:

Ziel_Trunk_Vodafone.jpg.2fceef3f90e9118e4330cca5d8a77d3b.jpg

 

Jedoch switched der Anruf dann auf den bestehenden ISDN-Trunk um:

Ziel_Trunk_ISDN.jpg.adc21db309267ef53e80dc18e9c6657e.jpg

Share this post


Link to post
Share on other sites
23 hours ago, Markus Wallner said:

Da Vodafone ohne Registrierung arbeitet, muss man denen auch mitteilen, dass der Link Manager auf Port 65002 lauscht und nicht auf 5060, sonst klappen die eingehenden Rufe nicht.

 

4 hours ago, SvenS said:

Dann bekommst du wohl keine Verbindung zu Vodafone. Schau mal mit Wireshark was passiert

 

 

Also auf der Firewall würde dazu eine NAT-Policy reichen, welche eingehend Port 5060 auf Port 65002 mapped.

Der angegebene Port 65002 ist ja der richtige und steht auch so in der Port-Doku von swyx:

Ports_LinkManager.jpg.1b38b63fa8a9962155a40c397b311354.jpg

 

 

Jedoch sieht man via netstat -a nicht, dass überhaupt etwas auf Port 65002 hört?

 

netstata.jpg.7fd64ec4b911c634896c872d7e520615.jpg

 

 

Mit Wireshark konnte festgestellt werden, dass sowohl die SBC IP(Proxy) und die SIP Domian(Realm) via Ping(ICMP-Pakete) erreichbar sind.

Wenn jedoch ein Testanruf ausgelöst wird und der Ziel-Trunk: "Vodafone" versucht eine Verbindung aufzubauen, ist im Wireshark kein Eintrag dazu vorhanden.

Pakete für einen Verbindungsaufbau im Wireshark werden erst dann ersichtlich, wenn der Testanruf vom Trunk "Vodafone" auf den vorhanden ISDN-Trunk wechselt.

 

SIP_Einstellungen.jpg.eb6d37f34de6ae7d8f00c47a6a9faabd.jpg

 

Was könnte man noch überprüfen?

 

Share this post


Link to post
Share on other sites
On 5/5/2021 at 4:43 PM, SvenS said:

Du gehst auch mit der richtigen IP zum VF SBC ? Siehst du in Wireshark überhaupt etwas wenn du den Filter nur auf die Vodafone SBC IP setzt ?

 

Die NAT-Regel war nicht korrekt, jetzt funktioniert das Ganze.

 

Danke für die Unterstützung.

 

Grüße

AGuser

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and have taken note of our Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.