Jump to content

Andreas_Hoffmann

Member
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Andreas_Hoffmann

  • Rank
    Newbie
  1. This works Public Shared Sub RemoveUserFromGroup(Group As String, User As String) Dim GroupToConfig As SWConfigDataClientLib.Proxies.Groups.GroupEntry Dim UserToConfig As SWConfigDataClientLib.Proxies.Users.UserEntry GroupToConfig = libManager.GetGroupEnum.AddUserToEnumByName(Group) UserToConfig = libManager.GetUserEnum.AddUserToEnumByName(User) Dim UserIDtoConfig As Int32 = UserToConfig.UserID Dim GroupIDtoConfig As Int32 = GroupToConfig.GroupID Dim GroupList As SWConfigDataClientLib.Proxies.Groups.MembershipEntryCollection GroupList = GroupToConfig.MembershipEntryCollection Dim i As Integer = -1 For Each groupentry In GroupList i += 1 If groupentry.ToString = UserIDtoConfig.ToString & GroupIDtoConfig.ToString Then Exit For End If Next GroupToConfig.MembershipEntryCollection.RemoveAt(i) GroupToConfig.Update(True) End Sub
  2. Hi, my following funktion working fine: Public Shared Sub AddUser(Group As String, User As String) Dim GroupToConfig As SWConfigDataClientLib.Proxies.Groups.GroupEntry Dim UserToConfig As SWConfigDataClientLib.Proxies.Users.UserEntry GroupToConfig = libManager.GetGroupEnum.AddUserToEnumByName(Group) UserToConfig = libManager.GetUserEnum.AddUserToEnumByName(User) Dim UserIDtoConfig As Int32 = UserToConfig.UserID Dim GroupIDtoConfig As Int32 = GroupToConfig.GroupID Dim GroupMapping As = New Proxies.Groups.MembershipEntry With { .GroupID = GroupIDtoConfig, .UserID = UserIDtoConfig, .Position = 0 } GroupToConfig.MembershipEntryCollection.Add(GroupMapping) GroupToConfig.Update(True) End Sub now I want to remove A User and have created a nearly same Sub - only the second last line is changed to GroupToConfig.MembershipEntryCollection.Remove(GroupMapping) nothing happening when I Use .RemoveAll() All Members deleted from group - but i cant remove a single User Any Idea what im doing wrong?? Im no developer an coding j4f like 30 years ago on c128d - thats why i do vb 😀 - no trace implementet yet
  3. Möglicherweise ist der Zweitanruf aktiviert, das würde Freizeichen, also Zustellversuche erklären. Innerhalb des VG Scriptes würde ich keine Ansagen einbauen. Mit einer neuen Regel über den GSE lässt sich Ansage vor melden schön realisieren. Eine Regel mit der Ansage bauen, Ansage abgespielt auf Regel übersprungen ziehen und die Regel vor die VisualGroups Regel stellen. Die Ansage kommt dann generell, ob Agenten frei oder besetzt...
  4. Ich hatte bei meinem Kunden das selbige Problem: Es wurden unterschiedliche Ziffern angehängt, auch bei internen Rufen. Ich hab dann mal die interne Rufnummer dreistellig vergeben und es wurde nichts mehr angehängt. Wir haben dann festgestellt dass bei meiner Handynummer +49160XXXXXXX, zwölf Ziffern, eine Ziffer hinzugefügt wurde und bei Anrufern >12 Ziffern nichts hinzugefügt wurde. Der Tapi Monitor und noch ein anderes Tool zeigte die Rufnummer natürlich immer korrekt an. Der Cobra "Support" Mitarbeiter sagte, Cobra wertet aus was die Anlage liefert, der TAPI Monitor hat ihn gar nicht interessiert, auch nicht was wir mit der Ziffernanzahl bemerkt hatten. Er sprach nur von Fakten und er kenne die Programmierung, blablabla... ich hab irgendwann aufgelegt, weil es eine kostenpflichtige Rufnummer war.. Auch in den TAPI Einstellungen, Anrufer ID haben wir rumgespielt, ohne Erfolg. Kooperativ ist Cobra nicht wirklich.. http://www.cobrasystem.de/faq/index.php?action=artikel&cat=22&id=85&artlang=de vielleicht sollte man den Wert von drei auf zwei ändern.. aber die sollen ihren Fehler selber suchen und finden.. wenn sie Lust haben
  5. Welcome to Swyx Forum :-)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and have taken note of our Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.